Saltar al contenido

  • Bienvenido a nuestra Comunidad

    Si quieres formar parte de nuestro foro y acceder a todas las funciones, regístrate o accede con tu cuenta de usuario.

Conéctate para seguir esto  
juanbe2626

Analisis interface Lexia3

Mensajes recomendados

Buenas a todos  de nuevo, con un poco de retraso debido a que he tenido que organizar todos los datos recopilados y por último después de realizar decenas de detecciones automáticas en el análisis se ha roto un relé de una de las interface que tengo.

Aqui os cuelgo el punto de trabajo

20171203_103426.jpg

20171203_143648.jpg

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios

Bueno empiezo a exponer el trabajo de analisis de la interface:

 

Mi interes ha sido comprender un poco mas o mejor como funciona la interface lexia, que es lo que sucede cuando se escanea y se pide que se identifique el vehiculo o cuando se hace un test global con Diagbox.

Espero con este tutorial que tanto los no profanos como los que tienen conocimientos de electronica comprendan el funcionamiento de la interface lexia3.

Leyendo en este foro http://cartechnology.co.uk/ encontré que en ciertas interface lexia presentaban en ciertas ocasiones con algún vehículo en particular un fallo leyendo através del BUS CAN, al acceder a los calculadores o identificar el vehiculo.

Pues comprobé en las dos interface Lexia que tengo (una NORMAL y otra FULL-CHIP) y compare placas PCB.

Aqui pongo unas fotos que saque de ese foro ofrecidas por el usuario "Titoun"

placaCC_caraB_titoun.jpg

Como podeis ver hay 5 placas, pero las dos de la izquierda hay una resistencia que no llevan y las otras 3 de la derecha si.

placaCC_caraB_2_titoun.jpg

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios

Interface FULL CHIP-juanbe2626

 

placaCC_caraB_juanbe2626.jpg

Como podeis ver, hay ciertas interface que no llevan ese componente, el cual es una resistencia SMD. Segun leí en el foro el valor de esa resistencia deberia ser de 103 (10kΩ). Y su fucnion es de trabajar como resistencia pull-up.

pull-up2.jpg

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios

La funcion de las resistencias pull-up es establecer un valor logico en estado de reposo, en este caso seria mantener en estado alto (5v) en ese pin o linea de datos FULL-CAN mientras esta en reposo esa linea. De esa forma colocando la resistencia se elimina la posibilidad que en estado de reposo haya presente ruido que genere una tension entre 0v a 5V.

 

Ahora bien las interface lexia que no llevan esta resistencia la suplen porque internamente el circuito intenta mantener en estado alto ese pin o en la linea FULL-CAN, el problema es que en ciertas ocasiones con ciertos vehiculos y ciertas peticiones de datos o comunicacion con la interface no se consigue mantener ese estado alto (reposo) la linea a 5v quedandose con menor voltaje y confundiendo a la interface, por lo que el programa o software Diagbox interpreta que no hay comunicacion (al identificar un vehiculo o leer un calculador especifico), pudiendo aparecer error de comunicacion o ausencia de dialogo.

 

Al mirar la tarjeta de relés, encuentro que el microcontrolador 16F684 juega es muy importante en el funcionamiento correcto de la interface. Todos los relés están controlados por el microchip a través de dos circuitos integrados de registro de desplazamiento. Si el 16F684 no funciona bien, nunca escucharemos sonido en los relés.

placaCC_caraA_juanbe2626_Rpull-up.jpg

Mis investigaciones me han llevado a mirar las especificaciones técnicas del fabricante del Microcontrolador. Se trata de un pic propietario de Fujitsu MB90F546GS de tipo que de 16bit dedicado en exclusiva para comunicaciones con lineas FULL-CAN y flash rom. Cuenta con 256Kb de ROM y 8Kb de RAM. Segun el fabricante en su página 40 de 68 especifica que la resistencia pull-up debe tener un valor entre 25k a 100k siendo su valor tipico de 50k.

Editado por juanbe2626

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios

Puntos de medicion con osciloscopio

placaCC_caraB_juanbe2626_puntos medicion.jpg

Cuando realizamos con Diagbox una deteccion automatica del vehiculo sucede lo siguiente:

 

Al sonar el primer relé, la tensión en la resistencia Rup baja a 0V desde los 4.95v, después del 2º sonido de relé sube de nuevo a 4.95v.

 

Editado por juanbe2626

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios

CLK PIC-R103_identific veh auto.jpg

imagen superior obtenida de una interface reduced- chip- Ch A= CLK PIC ; Ch B= pin R pull-up

cuando se estaba realizando un aidentificacion automatica de vehiculo con Diagbox 8.54.

R103-CLK PIC_identific veh automatica.jpg

imagen superior obtenida de una interface reduced- chip- Ch A= pin R pull-up ; Ch B= CLK PIC cuando se estaba realizando una identificacion automatica de vehiculo con Diagbox 8.54.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios

placaR_caraA_xmods_Ppuntos medicion filtro.jpg

Por lo que, quien tenga problemas de comunicacion con un vehiculo deberia primero mirar si su interface dispone de dicha resistencia. Yo en mi caso la he instalado de 50k (503). Tambien he realizado pruebas con resistencias de 27k.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios
hace 6 minutos, juanbe2626 dijo:

Espero no haber aburrido con demasiada información tecnica, he intentado ser lo más simple con las explicaciones y de forma detallada.

20171203_150937.jpg

 

Para nada!  a los que nos gusta esto estamos encantados con temas tan elaborados y que además tiene mucho trabajo por tu parte!

 

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios

Solo con el funcionamiento de los reles daria para otro tema largo, el cual tuve tambien que analizar a raiz de que la interface dejó de comunicarse con el coche después de realizar con ella decenas de mediciones en el laboratorio, al parecer un relé cascó. El fallo que presentaba era que al intentar detectar automaticamente el vehículo con Diagbox, daba error de comunicación, se escuchaba el típico sonido de relés pero los dos últimos relés se escuchaban muy debiles, al parecer el último relé que realiza la comunicación se habia quedado enclavado en la posicion de reposo y no conmutaba por lo que hacia 2 intentos (yo pensaba que eran dos relés pero resulto ser uno) antes de salir el error del fallo de comunicacion en Diagbox. Asi que me ha tocado cambiarlo y de paso aprender sobre ellos.:rolleyes:

Editado por juanbe2626

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios
hace 13 horas, Calculin69 dijo:

Muy buena info, aunque no entiendo apenas nada. Jaja.

Ese relé como y con qué lo cambias?

Bueno el relé es de la marca NEC modelo UD2-4.5NU, el encontrar repuesto de esto ha sido por aliexpress donde 2 relé de este  modelo me han salido por 1.41€ gastos incluidos.

20171216_111544.jpg

20171216_111629.jpg

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios

Se cambia con un soldador 30w punta fina, la pistola de aire caliente aquí es peligrosa debido a la cercanía de los demás relés y ademas que la carcasa son de plástico. Pero hay que quitarlos con mucho cuidado para no levantar las pistas.

 

Los relés funcionan a 4.5 voltios en su interior llevan dos conmutadores dobles, donde en estado de reposo se queda en contacto, pero para probarlos con aplicar 3.4v es suficiente. Son muy puñeteros porque sino los compruebas bien crees que funcionan.

Editado por juanbe2626

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios

Aunque desconozco totalmente la materia, me parece un tema de lo más interesante, e incluso, te animaría "abrirle las tripas" a un ELM, ya que aunque sus funciones son bastante más limitadas, tiene algunas funciones que me parecen interesantes, (como las de los relojitos).

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios
hace 7 horas, Calculin69 dijo:

La información técnica de los relés ya la conocía. El como sacarlos, me sigue pareciendo algo complicado. Soldador en algo tan pequeño, derretimiento seguro, jaja.

esta claro que pin a pin con un soldador es imposible. La técnica que yo uso es elegir los pines de la izquierda o los de la derecha, estonces les sueltas con el soldador suficiente estaño sobre los 4 pines como para que forme una linea continua que los una, después colocas el soldador con mucho cuidado en el centro y calienta toda la fila de pines bañadas con el estaño y entonces haces palanca ligeramente y levantas la zona de pines elegida completamente (derecha o izquierda) despues repites el proceso con la que quede y salen solitos. Una vez terminas retiras todo el estaño sobrante sobre los pines de PCB y las pistas.

 

Eso si, el pulso de cirujano porque como te desvies 1mm a la izquierda o derecha de donde este el soldador derrites el relé de al lado.:unsure:

Editado por juanbe2626

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios
Conéctate para seguir esto  

  • Nuestra selección

    • Error P2562 y P2563 Recopia Turbo
      Buenos días,
       
      Ayer al coger el coche vi como si le faltaba fuerza, hice una diagnosis y este fue el resultado.
      https://drive.google.com/folderview?id=0Bz_9eKlrza8YfmdwTGU3cjIwcHl2eXR3NnUxc1dRV2hES2xfZU5Oc0dad1FITXQ1RjJhOG8&usp=sharing
      • 8 respuestas
    • Preséntanos tu NUEVO Peugeot 208
      ¿Ya lo tienes? ¿Estás disfrutando de tu precioso NUEVO Peugeot 208 y quieres compartirlo con nosotros?
      Pues aquí estamos para que nos lo muestres orgulloso.
      • 105 respuestas
    • Testigo airbag parpadea
      Hola, hoy se me ha puesto a parpadear el testigo del airbag en mi Peugeot 306 break 2.0 HDI ¿alguna idea?
      • 16 respuestas
    • Altavoces Rifter
      Buenas,
       
      Hoy me he dado cuenta que con la música puesta, el altavoz de la puerta corredera del copiloto, retumba de una manera que no es normal, si estas dentro del coche apenas lo noto, pero si estás por fuera al lado de esa puerta retumba de tal manera, que parece que el altavoz está suelto. Incluso la puerta vibra. 
       
      Por otro lado al mirar si era porque estaba mal regulado el sonido y iba todo por ese lado, me he dado cuenta que el sonido que da un altavoz y el de la otra corredera es totalmente distinto. Mientras el del lado del copiloto retumba un montón, el otro suena como a enlatado. 
       
      Ya había quedado en llevarlo al taller para regularle la puerta lateral, así que les comentaré este tema también. 
       
      Un saludo. 
      • 12 respuestas
    • Foto del Mes Junio 2020
      Y ¡¡ya!!, que os estabais impacientando para subir vuestras participaciones de este mes 😜, ¿verdad @v8sport @Julian Rodriguez....??.
      Recordamos las normas:
       
      • 20 respuestas


REGALO GRATIS

Consigue tu regalo colaborando con el Club.
NUEVOS REGALOS


FOTO DEL MES

Envía tus mejores imágenes a la Foto del Mes. Cada mes elegimos un ganador.


COMPRA-VENTA

Un lugar para compra-venta entre miembros del Club.


PREGUNTA DE LA SEMANA

Participa en nuestra nueva sección.

×
×
  • Crear Nuevo...